I would call the variable something like disableFlowNodeSelection instead of disabled, as the render function contains multiple elements that potentially could be disabled, but the variable only affect some of them
I think the procDefIsNotSelected function should check the existence of a processDefinitionName and processDefinitionVersion instead of the xml
Might be a matter of taste, but I find positive method names easier to read, so I would rename procDefIsNotSelected to isProcDefSelected and have the negation when assigning the return value of the function to the disabled variable
Sebastian Stamm
added a comment -
I would call the variable something like disableFlowNodeSelection instead of disabled , as the render function contains multiple elements that potentially could be disabled, but the variable only affect some of them
I think the procDefIsNotSelected function should check the existence of a processDefinitionName and processDefinitionVersion instead of the xml
Might be a matter of taste, but I find positive method names easier to read, so I would rename procDefIsNotSelected to isProcDefSelected and have the negation when assigning the return value of the function to the disabled variable
I think it is more understandable if isProcDefSelected checks if processDefinitionKey and processDefinitionVersion is set instead of using double negation
Sebastian Stamm
added a comment -
I think it is more understandable if isProcDefSelected checks if processDefinitionKey and processDefinitionVersion is set instead of using double negation