Uploaded image for project: 'Camunda Optimize'
  1. Camunda Optimize
  2. OPT-2144

Update supported node version to latest LTS

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Done
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.5.0, 2.5.0-alpha1
    • Component/s: frontend
    • Labels:
      None

      Description

      We should support the latest node LTS: https://nodejs.org/en/

      We should make sure that users running the latest LTS version can:

      • Install the frontend
      • Run the frontend build for local development
      • Run the tests
      • Compile the frontend
      • Run related scripts like generating the dependency documents

      The Readme and documentation should be adjusted accordingly.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            sebastian.stamm Sebastian Stamm
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: