Uploaded image for project: 'camunda BPM'
  1. camunda BPM
  2. CAM-9206

Support for latest Java Version

    XMLWordPrintable

    Details

    • Type: Feature Request
    • Status: Closed
    • Priority: L3 - Default
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 7.10.0, 7.10.0-alpha4
    • Component/s: engine
    • Labels:
      None

      Description

      See also commit eb37f85.

      AT:

      • the Java versions 9, 10, 11 are supported
      • on JDK 9 and onwards distro/jbossas7 is excluded except webapp and webapp-standalone modules
      • maven enforcer plugin is updated to version 3.0.0-M1
      • maven assembly plugin is updated to version 3.1.0
      • jconsole dependency is excluded from wildfly-server
      • by default wildfly 11 engine integration tests are executed
      • test case SingleConsumerConditionTest#conditionStressTest fails randomly beginning with JDK 9 and onwards on CI as well as locally => Decided together with Daniel to remove it

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              nikola.koevski Nikola Koevski
              Reporter:
              roman.smirnov Smirnov Roman
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: